Power supply for Countess V4 Pedal

Gain_Junkie93

Can't handle 7's.
Joined
Jul 16, 2008
Messages
288
Reaction score
153
Location
Palm Bay,FL
So I bought the preamp used from guitar center and it came with no power supply. Went ahead and ordered a 12vdc 2a power supply from amazon and it is only lighting up the tubes not the leds. The power supply for my mooer radar trips when plugged into the preamp but lights the leds before shutting down. So it would seem the pedal is ok just I cannot for the life of me figure out why the supply I bought is not working. Idk anyone have one or could weigh in?
 

High Plains Drifter

... drifting...
Joined
Aug 29, 2015
Messages
3,651
Reaction score
4,359
Location
Austin, Texas
Did you check to make sure that the polarity is correct? Just wondering since you ordered the supply separately. The V4 utilizes a negative polarity plug.
 

Gain_Junkie93

Can't handle 7's.
Joined
Jul 16, 2008
Messages
288
Reaction score
153
Location
Palm Bay,FL
Got a negative center pin 12v 1a powersupply in the mail and it worked for 15 minutes till the pedal shut off and the box of the supply was hot as hell. That power supply is now dead. So I got a negative center 12v 2a supply and that is causing the lights to click twice in quick succession similar to how the mooer radar's supply had done clearly tripping the circuit for whatever reason. At this point I am beyond frustrated. Searching online the only advice I'm seeing for powering it is a powermax or other roughly $150-200 pedalboard power supply bricks. I'm tempted to return it just because of the hassle this has been are there seriously not any readily available solutions?
 

High Plains Drifter

... drifting...
Joined
Aug 29, 2015
Messages
3,651
Reaction score
4,359
Location
Austin, Texas
The issue likely is that the unit is now damaged if you already inserted the wrong plug into it. I damaged a pedal before doing the exact same thing.
 


Top