NAD And fuck!!! WTF IS WRONG??? HELP!

harkonnen8

SS.org Regular
Joined
Oct 30, 2007
Messages
340
Reaction score
22
Location
Latvia
Well i bought 5150. And something is fuckin' wrong! The sound is verry brittle, unbeliveble amount of hiss and harsh sounds. So please ask me questions and help me :flame:

Sorry i'm completely noob at everything but why does rhythm channel doesn't have a distortion (well, the rhythm channel sounds good (is it clean channel?), but the lead channel sounds like anus giving birth to another anus(thus incredibly wrong) and controls (on the lead channel) seems to be completely not responsive.

And there was that crackling(actually it sounded like someone is doing something with paper :D)sound whenever i turned eq button up or down

The amp is used and it looks like it has been gathering dust for a while.
 
Last edited:

sami

porkshop sammiches
Joined
Sep 23, 2008
Messages
4,762
Reaction score
760
Location
Austin TX USA
sounds like you bought a pretty old and unused/uncared for amp.

Scratchy pots are caused by dirt/dust/etc. Try some canned air and hope you don't need to replace them. Because of said condition, i bet you seriously need to replace all the tubes....or don't put the gain at 10!
 

BurialWithin

NAM SAND!!
Joined
Sep 14, 2008
Messages
997
Reaction score
61
Location
Horn Lake, MS.
yea seriously i bet it's like dirty pots and bad tubes mine did that i took it to a amp guy person to fix and replace things and what nots in there and old "stuff" i don't know :scratch: but now it sounds clean and punchy and like clear and brand spankin new almost like a brand new tire on a basketball court.
 

JJ Rodriguez

Contributor
Joined
Aug 16, 2005
Messages
14,746
Reaction score
1,356
Get some contact cleaner for the pots, replace the tubes, and go from there.
 

harkonnen8

SS.org Regular
Joined
Oct 30, 2007
Messages
340
Reaction score
22
Location
Latvia
sounds like you bought a pretty old and unused/uncared for amp.

Scratchy pots are caused by dirt/dust/etc. Try some canned air and hope you don't need to replace them. Because of said condition, i bet you seriously need to replace all the tubes....or don't put the gain at 10!

on 0.00001 it already sounds like shit fucked garbage can full of razorblades.(thus broken)

I serioussly cant even play anything it sounds like there is no bass no mids and ultra scratchy, crackling, digitalized, brittle, harsh. Fuck!!
It sounds like something needs to be fixed :D And it isn't funny. It is 100% unplayable, except for the clean channel (so is it rhythm channel wtf).
 

The Dark Wolf

Contributor
Joined
Apr 15, 2005
Messages
17,582
Reaction score
995
Location
Toledo, Ohio. USA
Dude, follow JJ's advice. It sounds like seriously you got some dust/grime issues, and almost certainly need new tubes. It's going to sound like ass if the tubes are ancient and beat to fuck.
 

The Dark Wolf

Contributor
Joined
Apr 15, 2005
Messages
17,582
Reaction score
995
Location
Toledo, Ohio. USA
Dude, follow JJ's advice. It sounds like seriously you got some dust/grime issues, and almost certainly need new tubes. It's going to sound like ass if the tubes are ancient and beat to fuck.
 

harkonnen8

SS.org Regular
Joined
Oct 30, 2007
Messages
340
Reaction score
22
Location
Latvia
Dude, follow JJ's advice. It sounds like seriously you got some dust/grime issues, and almost certainly need new tubes. It's going to sound like ass if the tubes are ancient and beat to fuck.

Now You See My wallet, Now You Don't. :realmad:

:wallbash: :wallbash: :wallbash:

Fuck,

I don't want to take it to tech. My wallet will not survive this for sure.

And why the F*** rhythm channel ( so is it clean channel or what? ) sounds ok ( no problem at all ( well almost))?

I'll post some pics a bit later.
 

synrgy

Ya ya ya I am Lorde
Joined
Jan 28, 2009
Messages
6,628
Reaction score
1,332
Location
Frederick, MD
Now You See My wallet, Now You Don't. :realmad:

:wallbash: :wallbash: :wallbash:

Fuck,

I don't want to take it to tech. My wallet will not this for sure.

And why the F*** rhythm channel ( so is it clean channel or what? ) sounds ok ( no problem at all ( well almost))?

I'll post some pics a bit later.

It doesn't take a tech to change tubes and clean pots. If you can tie your own shoes, you can probably pull it off.
 

harkonnen8

SS.org Regular
Joined
Oct 30, 2007
Messages
340
Reaction score
22
Location
Latvia
You'd be surprised, but go ahead and be stubborn stupid if you want. It's your amp, bro.

No, no, no. I'm just asking, because it sounds really bad (The lead channel). Anyway I'll retube it and clean it of course. Sorry man i didn't want to sound like a complete ass.
 

JJ Rodriguez

Contributor
Joined
Aug 16, 2005
Messages
14,746
Reaction score
1,356
Just how bad could sound raped ancient tubes? I think the problem might be bigger than that. :noplease:

Well I think the fact that your "Rhythm" (5150's semi clean channel? Not sure) is fine and the lead channel sounds like balls is pretty telling. Your amp will use your first pre-amp tube for your input buffer and first gain stage, then that tube and the next tube for more gain on the next channel, etc. I don't know the tube mapping for the 5150, but if you think about it like that it makes sense that the final tube used for that gain stage is fucked. Snag some pre-amp tubes, they're cheap and easy to swap out, so it's a quick test. Contact cleaner is cheap as fuck too, it's just a liquid you spray onto the pots, then turn them to get the shit in there (DO THIS WITH THE AMP OFF) and get the cleaning done. Yeah, the problem MIGHT be bigger than that, but it almost might be as small as that.
 

harkonnen8

SS.org Regular
Joined
Oct 30, 2007
Messages
340
Reaction score
22
Location
Latvia
Well I think the fact that your "Rhythm" (5150's semi clean channel? Not sure) is fine and the lead channel sounds like balls is pretty telling. Your amp will use your first pre-amp tube for your input buffer and first gain stage, then that tube and the next tube for more gain on the next channel, etc. I don't know the tube mapping for the 5150, but if you think about it like that it makes sense that the final tube used for that gain stage is fucked. Snag some pre-amp tubes, they're cheap and easy to swap out, so it's a quick test. Contact cleaner is cheap as fuck too, it's just a liquid you spray onto the pots, then turn them to get the shit in there (DO THIS WITH THE AMP OFF) and get the cleaning done. Yeah, the problem MIGHT be bigger than that, but it almost might be as small as that.

Thanks man! :bowdown:
 

The Dark Wolf

Contributor
Joined
Apr 15, 2005
Messages
17,582
Reaction score
995
Location
Toledo, Ohio. USA
^ Exactly.

In audio stuff, when there's an issue, and you're not sure exactly what it is, start with the smallest, simplest stuff first, and work your way through the system, going up in complexity. Generally a good rule of thumb.
 

thedonutman

SS.org Regular
Joined
Jan 27, 2007
Messages
1,336
Reaction score
134
Location
UK
I was always under the impression that the 5150's Rhythm channel was actually a clean channel, with the Clean/Crunch option.

I've not had much experience with 5150s to say for sure though.
 

harkonnen8

SS.org Regular
Joined
Oct 30, 2007
Messages
340
Reaction score
22
Location
Latvia
Here's another stupid queston for you. How do i open it? :D Which screws do i have to unscrew. I'm sorry. I'm new to this.
 


Top