Mooer Ge300

LiveOVErdrive

CNC hack
Joined
Aug 17, 2016
Messages
3,320
Reaction score
2,834
Location
Minneapolis, MN
Very cool. I'll have to pick up the mark 3 one at some point. And maybe the blackmore. And the mark 4.

Maybe I should just grab the ge300 :)
 

Nhoj

SS.org Regular
Joined
Apr 22, 2018
Messages
105
Reaction score
33
37874031_1361076954027454_8998484632953421824_n.jpg
 

Metropolis

SS.org Regular
Joined
Mar 16, 2010
Messages
2,000
Reaction score
2,072
Location
Vantaa, Finland
Bruh....there are already gently used ones on Reverb and elsewhere for a little over $200. What are you waiting for?

I'm lazy and don't want to dig up the GE200 thread. Have they fixed issue with reverb and delay tails in later firmwares when changing presets? And is there possibility that IR resolution length has been improved from 512 samples to higher in later versions?
 

LiveOVErdrive

CNC hack
Joined
Aug 17, 2016
Messages
3,320
Reaction score
2,834
Location
Minneapolis, MN
I'm lazy and don't want to dig up the GE200 thread. Have they fixed issue with reverb and delay tails in later firmwares when changing presets? And is there possibility that IR resolution length has been improved from 512 samples to higher in later versions?
I don't think so. They have firmware patch notes on the mooer website and they don't mention that.
 

Nhoj

SS.org Regular
Joined
Apr 22, 2018
Messages
105
Reaction score
33
GE300 is release first China
 

LiveOVErdrive

CNC hack
Joined
Aug 17, 2016
Messages
3,320
Reaction score
2,834
Location
Minneapolis, MN
So as mentioned above, I just got myself a GE200. The thing has a lot of potential and feels ruggedly built, but the sound is ... off.

Most of the high gain models sound super bloated, like the input signal has a TON of bass in it and is just mudding up the overdrive section. Palm mutes sound gross and boomy, in a really lo-fi kind of way. The Mark V, the Mark III, the Recto, even the 5150 and 5153 models all have this problem. The ENGLs are better but still not great. I can hear the character of the amps coming through above it, though, and they sound great.

Basically I can't get a good sound from any of the sims without putting a boost in front of it. Am I doing something dumb? Maybe I should try a different cable or something. I've tried different guitars.
 

LiveOVErdrive

CNC hack
Joined
Aug 17, 2016
Messages
3,320
Reaction score
2,834
Location
Minneapolis, MN
Update. Cable was not the issue. Looks like something is just rotten in the sim. And yet I can't find anyone complaining about this online. Perhaps it is just a headphone issue, as that's the only way I've listened so far.
 

Nhoj

SS.org Regular
Joined
Apr 22, 2018
Messages
105
Reaction score
33
Update. Cable was not the issue. Looks like something is just rotten in the sim. And yet I can't find anyone complaining about this online. Perhaps it is just a headphone issue, as that's the only way I've listened so far.

GE300 will be released soon.
 

Spinedriver

SS.org Regular
Joined
Jan 22, 2007
Messages
2,985
Reaction score
787
Location
NB,Canuckistan
So as mentioned above, I just got myself a GE200. The thing has a lot of potential and feels ruggedly built, but the sound is ... off.

Most of the high gain models sound super bloated, like the input signal has a TON of bass in it and is just mudding up the overdrive section. Palm mutes sound gross and boomy, in a really lo-fi kind of way. The Mark V, the Mark III, the Recto, even the 5150 and 5153 models all have this problem. The ENGLs are better but still not great. I can hear the character of the amps coming through above it, though, and they sound great.

Basically I can't get a good sound from any of the sims without putting a boost in front of it. Am I doing something dumb? Maybe I should try a different cable or something. I've tried different guitars.

Generally, stock cabs in 'budget' modellers aren't very good, so perhaps replacing them with some others (GuitarHacks, Ownhammer, 3 Sigma, etc..) might get you some better results.
 


Top