Decimator II G-String Not Working?

Discussion in 'Gear & Equipment' started by decreebass, Jun 13, 2015.

  1. decreebass

    decreebass ...Mulva?

    Messages:
    1,370
    Likes Received:
    300
    Joined:
    Mar 14, 2013
    Location:
    Mililani, Hawai'i
    I am at my wits end - I was having issues with this pedal the day I got it; I ended up switching cables around and it began working - so I assumed it was user error.

    Well, now I finally put together my ultimate pedalboard and the one thing that doesn't seem to want to play nice is the Decimator. It made practice a total drag since having it in the loop made whole loop not work right. As soon as I took it out of the setup everything worked fine, except for the ridiculous amount of noise...

    Anyway, I got home and am trying to fix/diagnose things and the Decimator is definitely the problem child. It's a little difficult to know for sure since I don't have the amount of noise that I have at the rehearsal studio (absolute crap power & interference there...).

    When I isolate the Decimator, here's my setup:
    Guitar > Decimator "Guitar In"
    Dec "Guitar Out" > amp input
    Amp FX Send > Dec "Dec In"
    Dec "Dec Out" to FX Return

    Now, whether the unit is turned on or off, there's no difference in sound. The light comes on, but no matter what the threshold is set to, no "gate" ever kills what little noise there is.

    I guess I'm desperate for someone to tell me that I'm doing something wrong. I REALLY don't want to deal with shipping this back to Sweetwater for a replacement or having to buy a new one if for some reason they tell me it's past its warranty or something.

    Super frustrated right now - I just dropped about $600 on a new Pedaltrain, power supply, and patch cables and I really need this to work. Any help or suggestions or commiseration is welcome.
     
  2. decreebass

    decreebass ...Mulva?

    Messages:
    1,370
    Likes Received:
    300
    Joined:
    Mar 14, 2013
    Location:
    Mililani, Hawai'i
    update: pretty sure the pedal is broken. sending it back today or ASAP.
     
  3. 155

    155 SS.org Regular

    Messages:
    683
    Likes Received:
    64
    Joined:
    Jun 24, 2009
    Location:
    ct
    mine .... the bed once they fixed for $25
     
  4. decreebass

    decreebass ...Mulva?

    Messages:
    1,370
    Likes Received:
    300
    Joined:
    Mar 14, 2013
    Location:
    Mililani, Hawai'i
    So I'm not the only one - it's a shame, too. It's such an incredibly sturdy tank of a pedal. No idea what makes it so succeptible to internal damage. Honestly, I kinda wish it was lighter weight! I feel like the velcro on my pedalboard doesn't appreciate the G-String's heft :)
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.