Bugera 6262 infinium stopped working

Discussion in 'Gear & Equipment' started by guitar_dude1990, May 31, 2014.

  1. guitar_dude1990

    guitar_dude1990 New Member

    Messages:
    2
    Likes Received:
    0
    Joined:
    May 31, 2014
    Location:
    Australia
    Hey guys I own a bugera6262 infiniium in was dated 11/11 so I'm guessing it's the first infinium run any way I was using it last night and all of a sudden all the lights on the front panel die and the power tubes started getting dark purple and red hot they are getting hotter and hotter I though they would explode there was humming a hissing coming from the speakers so I shut it down now earlier on during the day one of the infinium lights kept flashing and stayed on it was for the number 4 power tube but it looked fine and sounded great. So now my amps tubes still heat up there are no channel led lights or power lights but the amps tubes still heat up when I flick the standbuy switch to on the tubes go purple and started getting red red hot so I've left it now.
    I've had the amp for 3 years so warranty is out of the question I've emailed bugera just waiting on them. Please help lol
     
  2. WestOfSeven

    WestOfSeven SS.org Regular

    Messages:
    333
    Likes Received:
    35
    Joined:
    Apr 24, 2013
    Location:
    Canada
    Just get a US made 6505 or 5150.

    Those bugeras are garbage made with the cheapest parts possible. Even if you do manage to fix it how long until another component fails?
     
  3. guitar_dude1990

    guitar_dude1990 New Member

    Messages:
    2
    Likes Received:
    0
    Joined:
    May 31, 2014
    Location:
    Australia
    usa made 6505s 5150s are way over priced here in aus you would be lucky to find a used one under 1200 au. Well if the bugera is an easy fix and it gives me another 4 years id be happy I only paid 600 for it
     
  4. viesczy

    viesczy SS.org Regular

    Messages:
    1,026
    Likes Received:
    61
    Joined:
    Jan 6, 2005
    Location:
    On the fretboard!
    Easiest way, replace your 4 power tubes and your fuses.

    Should cure it all.

    Good luck.

    Derek
     
  5. WarMachine

    WarMachine SS.org Regular

    Messages:
    2,243
    Likes Received:
    715
    Joined:
    Jan 19, 2012
    Location:
    Charleston, WV
    Check youtube dude, there is a plastic connector (duh i know) that has the leadwires that go to the board and over some time they just get too hot, melt and then that's what breaks your circuit. Newark had that same connector clip type for like $0.04 a piece when i bought some and it cured it. Good luck dude :wavey:
     
  6. Albionic

    Albionic First of the magi

    Messages:
    1,756
    Likes Received:
    75
    Joined:
    Dec 16, 2010
    Location:
    London uk
    i think as this is the newer infinium model that the plastic clip fault was sorted by then. I could be wrong though
     
  7. WarMachine

    WarMachine SS.org Regular

    Messages:
    2,243
    Likes Received:
    715
    Joined:
    Jan 19, 2012
    Location:
    Charleston, WV
    Good possibility, mine was one of the dreaded launch series :lol:
     
  8. seven-eleven

    seven-eleven SS.org Regular

    Messages:
    56
    Likes Received:
    7
    Joined:
    Dec 14, 2011
    Location:
    Melbourne australia
    Where do you live in Australia?

    I got a evh 5153 50watt for $800 used you can pick up 6505s for
    1000.

    newhttp://www.guitarfactory.com.au/Amps/Peavey/6505_Series?gclid=CjkKEQjwqsCcBRDt7_Gts5a91YYBEiQAm-wYEfs1U3fmjRpa2g7c8hhTKsJ3sxxLcqmbQpMaEa_dYQfw_wcB

    Also found a randall rm100 brand new with 3 modules for 1000, the ultra xl stock module sounds great.

    Do yourself a favour and get rid of the bugera such a waste of money.

    If you wanted to spend a little more you can get,
    Engl fireball 100 - 1200.
    Marshall jvm 410 - 1500
    Mesa boogie dual - 1500
    Engl powerball II - 1500
     
  9. lewis

    lewis SS.org Regular

    Messages:
    7,916
    Likes Received:
    4,351
    Joined:
    Aug 16, 2011
    Location:
    Norfolk, UK
    "Bugera 6262 infinium stopped working"

    of course it did..... thats why I never bought one. Wanted one for a long time and bought an Ironheart instead so that too could pack up on me. Valve amps FTW :noway:

    Pod Hd Pro from now on
     
  10. viesczy

    viesczy SS.org Regular

    Messages:
    1,026
    Likes Received:
    61
    Joined:
    Jan 6, 2005
    Location:
    On the fretboard!
    Engl and their build quality for the price they demand? Really? C'mon. Might as well stay with the Bugera.

    And Engl sit behind the entire mix too. Hardest fight I ever had, beyond the time I knocked the taste outta Mike Tyson's mouth ;), was dialing in the PBII at band volume. Sent that back right quick and in a jiffy and went with the Road King II.

    Derek
     

Share This Page