Randall Cyclone help?

Discussion in 'Gear & Equipment' started by bleedingeye667, Feb 12, 2017.

  1. bleedingeye667

    bleedingeye667 SS.org Regular

    Messages:
    2
    Likes Received:
    0
    Joined:
    May 7, 2015
    Location:
    Alliance, OH
    I found this wonderful amp in a pawn shop and had to have it. Once I got it and hooked it all up, I noticed something quite annoying. With the gain on 1 or above, I get an ungodly squeal that will only go away if I switch to the clean channel. I run four cable method with a line 6 board, a noise gate in the front and the effects loop. Mind you, this squeal does not happen at lower volumes. I even tried running the direct out into the effects return of my RD45 for a different power source and it still happens. Nothing extreme on my eq either. Can anyone help me out? I play with a guy who uses an RM100 so the issue is rather apparent in a full band setting
     
  2. Fretless

    Fretless Knob Fiddler Contributor

    Messages:
    1,756
    Likes Received:
    130
    Joined:
    Oct 18, 2013
    Location:
    Houston, TX
    Does this squeal happen if your guitar is muted, or only if you're trying to play?
     
  3. bleedingeye667

    bleedingeye667 SS.org Regular

    Messages:
    2
    Likes Received:
    0
    Joined:
    May 7, 2015
    Location:
    Alliance, OH
    While muted or also while hitting some single notes after it starts. Mind you I don't think it's a volume issue or being too close, as my Diavlo or my old RM100 didn't have that problem, bot to mention the noise gates.
     
  4. vick1000

    vick1000 SS.org Regular

    Messages:
    2,639
    Likes Received:
    154
    Joined:
    Feb 4, 2013
    Location:
    Florida
    Probably a low pass filter cap is bad or shorted.
     
  5. BlasphemyMadeFlesh

    BlasphemyMadeFlesh Buried in the mix

    Messages:
    77
    Likes Received:
    15
    Joined:
    Feb 9, 2014
    Location:
    Los Angeles, CA
    I'm no electronics expert by any means but I had a similar problem with my Warhead (it's design has a lot in common with your Cyclone.) Distortion channel would squeal by itself like an analog synth when gain and the volume were up at playing level. It was solved when the input jack was replaced.
    Good luck getting yours fixed, I love these amps.
     

Share This Page